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Preface
Figure Maker is an additional module for QuickPHOTO programs for creating composite
figures with scale bars and labels intended for publications.
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Installation
Important

For the successful Figure Maker module installation it is necessary to have the
QuickPHOTOCAMERA,QuickPHOTOMICRO orQuickPHOTO INDUSTRIAL
program in version 3.0 or newer installed on your computer.

Note

In case you do not have the permission to use the Figure Maker module contained
in your QuickPHOTO dongle or you are installing the module into a trial version
of the one of the above mentioned programs (no dongle is used), the Figure Maker
module will run in a mode of a demo version. The demo version provides all the
functions of a full version, but a watermark will be inserted into the created figures.
Each time you will run the demo version you will be informed about that fact. If
you want to purchase a full version, contact yourQuickPHOTO software supplier.

If you are going to install Figure Maker module from a supplied installation disk, insert it
into your DVD drive. An autorun screen will appear. If the autorun screen does not appear,
launch the autorun.exe file from the installation disk manually. Select Install Figure Maker
option.

If you are going to install Figure Maker module from a downloaded installation package,
run it and select the destination folder, where the installation files should be extracted.
Wait until the installation files will be extracted and an installation wizard will appear.

An installation wizard will appear. Select the desired language and continue by the Next
button. The wizard will search your computer for installed QuickPHOTO CAMERA,
QuickPHOTO MICRO or QuickPHOTO INDUSTRIAL programs. In case there is more
then one QuickPHOTO version installed on your computer, choose from the displayed list
the desired version into which the Figure Maker module should be installed and click the
Next button.

Continue following the on-screen instructions.
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Graphical User Interface Description
The main window of Figure Maker module is divided into several parts:

• Menu bar (1)- contains menus with individual options.
• Toolbar (2) - contains tool buttons.
• Thumbnail Browser (3) - displays thumbnails of all imported images.
• Navigator (4) - is used for selection of displayed area and zoom of selected image.
• Workspace (5) - is a space into which the images can be inserted to create composite

figures.
• Side bar Tools (6) - contains tools for insertion of scale bars and labels.
• Status bar (7) - contains information about the size of a selected image in the resulting

figure and control elements for workspace zooming.
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1. Menu Bar
Menu File

Menu File contains following options:

New Project... - runs a new project creating wizard. [Ctrl+N]

Open Project... - opens saved project. [Ctrl+O]

Open Recent Project - offers last used projects for opening.

Save Project - saves current project. If the project has already been saved before, it will
be saved again into its original location. If you are saving newly created project a Save As
dialog window, which will enable you to choose project file location and its name, will be
displayed. [Ctrl+S]

Save Project As... - opens a Save As dialog window, which will enable you to choose project
file location and its name. [Ctrl+Shift+S]

Import Images... - runs a wizard for importing images into the current project. [Ctrl+I]

Export Figure... - runs a wizard for figure exporting. [Ctrl+E]

Image Information... - displays information about the selected image.

Close Selected Images - closes all images selected in the Thumbnail Browser and removes
them from the current project. [Ctrl+W]
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Close All Images - closes all images displayed in the Thumbnail Browser and removes
them from the current project. [Ctrl+Alt+W]

Exit - closes Figure Maker module. [Alt+X]

Menu Edit

Menu Edit contains following options:

Undo - takes back the last performed action. It is possible to take back as many
consecutively performed actions as you wish. [Ctrl+Z]

Redo - will again perform the action taken back using the Undo function. [Ctrl+Y]

Remove Selected Image from Workspace - removes selected image from the workspace.
[Delete]

Remove All Images from Workspace - removes all images from the workspace.

Canvas Properties... - displays Project Properties dialog window with opened tabCanvas.
Canvas properties can be changed only when images are not placed on the workspace.

Grid Properties... - displays Project Properties dialog window with opened tab Grid.

Project Information... - displays Project Properties dialog window with opened tab
Information.

Snap to Images - turns on/off snapping to images feature.

Snap to Grid and Edges - turns on/off snapping to grid and edges of the workspace feature.
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Options... - opens dialog window with Figure Maker module settings.

Menu Help

Menu Help contains following options:

Help... - opens an electronic user manual.

About... - displays information about Figure Maker module.

2. Toolbar
Individual program functions can also be activated using the following buttons from the
Toolbar:

Open Project... - opens saved project. [Ctrl+O]

Save Project - saves current project. If the project has already been saved
before, it will be saved again into its original location. If you are saving
newly created project a Save As dialog window, which will enable you to
choose project file location and its name, will be displayed. [Ctrl+S]

Import Images... - runs a wizard for importing images into the current
project. [Ctrl+I]

Export Figure... - runs a wizard for figure exporting. [Ctrl+E]

Undo - takes back the last performed action. It is possible to take back as many
consecutively performed actions as you wish. [Ctrl+Z]
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Redo - will again perform the action taken back using theUndo function. [Ctrl+Y]

Canvas Properties... - displays Project Properties dialog window with
opened tabCanvas. Canvas properties can be changed only when images
are not placed on the workspace.

Grid Properties... - displaysProject Properties dialog window with opened
tab Grid.

Project Information... - displays Project Properties dialog window
with opened tab Information.

3. Thumbnail Browser
Thumbnails of images imported into the current project are displayed in the Thumbnail
Browser together with the image names, sizes in pixels and calibration information.

If you move the mouse over a thumbnail of one of the imported images, four buttons will
appear next to it. These buttons activate functions for the particular image.

Insert Image into the Workspace button - places image into the workspace.
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Images, which are placed on the workspace, have an orange square with a number displayed
in the upper left corner of the thumbnail. The number indicates how many times is the
particular image present on the workspace. Images, which do not have an orange square
displayed in the thumbnail are not yet placed on the workspace. Each image can be placed
to the workspace multiple times and each time a different area of it can be displayed.

Remove Selected Image from the Workspace button - removes the selected image from
the workspace. Delete key can also be used for image removal. The image stays displayed
in the Thumbnail Browser.

Image Information button - displays Image Information dialog window. In that dialog
window a short image description can be entered/displayed and if the image contains
calibration information, its detail can be also displayed. If the image contains description,
an indicator Image Contains Description will be displayed next to the corresponding
thumbnail. If you entered an image description in QuickPHOTO program and imported
the image from it, the image description will be available also in Figure Maker module.
The image description will be stored within a Figure Maker project file and you can return
to it anytime.

Note

If you use the Figure Maker module in QuickPHOTO program in version 3.0, the
image descriptions will not be displayed for images imported fromQuickPHOTO
program.

Close and Remove Image from Current Project button - removes all inserted image
"copies" from the workspace and removes the image also from the current project. The
image will be removed also from the Thumbnail Browser and the only way how to return
it to the current project is by importing it again.
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If the image contains calibration information, an indicator will be displayed next to the
corresponding thumbnail and there will be displayed also information about used
magnification e.g. Objective: 0.75; Zoom: 0.8 below the information about image
dimensions in pixels. If the image does not contain calibration information ( indicator
is not displayed), a scale bar cannot be inserted into it.

Note

If you use the Figure Maker module in QuickPHOTO program in version 3.0, the
calibration information and original names of images imported fromQuickPHOTO
program will not be displayed in the Thumbnail Browser. The original image
names will be replaced by numbered placeholder names.

Selection of a single image in the Thumbnail Browser can be done by a single click of the
left mouse button on the corresponding thumbnail. Continuous selection of several images
in the Thumbnail Browser can be done by clicking the mouse on the first thumbnail and
then on the very last one of your selection, while holding the Shift key. Discontinuous
selection of images in theThumbnail Browser can be done by selection of desired thumbnails
with the left mouse button, while holding the Ctrl key. Canceling the selection of multiple
thumbnails can be done by clicking the left mouse button on a random thumbnail.

Order of thumbnails in the Thumbnail Browser can be changed by dragging them with
a mouse (drag and drop).

To gain a larger area for the workspace, you can hide (slip in to the left) the Thumbnail
Browser by clicking the button, in its right upper corner. This button then will change
to button. This way the Thumbnail Browser will free up and if you move the mouse
cursor outside of the Thumbnail Browser, it will be slipped in to the left. In this case, you
may work with the Thumbnail Browser by moving the mouse onto the vertically oriented
Thumbnail Browser tab on the left side of the main window of Figure Maker module - the
Thumbnail Browserwill be pulled out. Its anchoring can be done by clicking the button.

15

Graphical User Interface Description



Note

The thumbnail size is the same as the thumbnail size set inQuickPHOTO program.

4. Navigator
In the left bottom part of the main window of Figure Maker module there is a Navigator
with the selected image displayed.

The zoom of the image selected on the workspace can be increased or decreased by a slider,
by and buttons below the Navigator, by a mouse wheel, when the mouse cursor is
placed above the Navigator or using the editable drop-down menu next to a slider. A range
of available zoom values is indicated by minimal and maximal values below the slider.
Minimal value changes according the current size of the image on the workspace and can
differ for particular images. To achieve the optimal print results, the image zoom should
not exceed 100%, if possible. If the zoom value is greater than 100% a warning indicator

will display next to the drop-down menu with the current zoom value.

In the Navigator window, the area of the image that is currently visible on the workspace
is framed. You can move the frame by dragging it or move it to the desired location by
clicking the left mouse button. Move the frame to display the desired image area on the
workspace.
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5. Tools Side Bar
Tools side bar contains control elements for insertion of scale bars and labels. Control
elements are located on the two tabs: Scale Bar and Labels.

To gain a larger area for the workspace, you can hide (slip in to the right) the Tools side
bar by clicking the button, in its right upper corner. This button then will change to
button. This way the Tools side bar will free up and if you move the mouse cursor outside
of the Tools side bar, it will be slipped in to the right. In this case, you may work with the
Tools side bar by moving the mouse onto the vertically oriented Tools tab on the right side
of the main window of Figure Maker module - the Tools side bar will be pulled out. Its
anchoring can be done by clicking the button.

5.1. Scale Bar Tab
Scale Bar tab contains control elements for setting length, properties and appearance of
scale bars and for their insertion into images.
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Insert Scale Bar into All Images - this control
element contains two buttons. Horizontal button
inserts horizontal and Vertical button inserts vertical
scale bar into all images on the workspace containing
calibration information. Scale bars will be inserted
according to the settings described in following
paragraphs.
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Scale Bar in Selected Image - this control element
contains two buttons.Horizontal button inserts/hides
horizontal scale bar in the image selected on the
workspace. Vertical button inserts/hides vertical
scale bar in the image selected on the workspace.
Scale bar will be inserted according to the settings
described in following paragraphs. In order to be
able to insert the scale bar into the selected image,
it needs to contain calibration information. If the
selected image does not contain calibration
information, both buttons will be disabled and
following information will be displayed below them:
Scale bar cannot be inserted into selected image. It
does not contain calibration information. These
buttons serve also as indicators, whether the scale
bar is inserted into the selected image.

Following control elements enable setting parameters and appearance of the scale bars.

Note

The units can be changed in module options: Edit → Options...

Length - using this control element you can define a desired scale
bar length and units. You can select one of the predefined values
from the first drop-down menu or type desired value into it. Units
can be selected in the second drop-down menu.

Thickness - using this control element you can define a scale bar
thickness in units selected in module Options.

Position - using this control element you can define
a position of a scale bar in the image.
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Offset - these control elements enable to define
a scale bar's offset from an image corner in units
defined in module Options.

Appearance - using these control elements you can
define appearance of a scale bar:

Invert Colors - if this option is not checked, a scale
bar will be inserted as a black bar. If the Display
Background option is checked, a black scale bar will
be placed on a white background. If you check the
Invert Colors option, a scale will be inserted as
a white bar instead of a black one. If the Display
Background option is checked, a white scale bar will
be placed on a black background.

Display Value - if this option is not checked, a scale
bar will be inserted as a bar without any numerical
value. If you check this option, a scale bar will be
inserted along with a numerical value displaying its
length in units selected in Length part. You can also
define whether the value should be positioned above
or under a scale bar. Furthermore you can define, if
a background should be displayed behind a scale bar
and its value using the Display Background option.

Font - using these control elements you can set font
and size of a scale bar length value.

20

Graphical User Interface Description



Apply to All Inserted Scale Bars - if you perform
any changes in settings of a scale bar in any of the
images on the workspace, you can apply all those
changes to all scale bars inserted into images on the
workspace at once by clicking this button.

5.2. Labels Tab
Labels tab contains control elements for setting properties of labels and for their insertion
into images.
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Automatic Labeling - this part contains three buttons.
A,B,C,... button automatically labels all images on
the workspace by capital letters starting with A letter.
a,b,c,... button automatically labels all images on
the workspace by lowercase letters starting with a
letter. 1,2,3,... button automatically numbers all
images on the workspace starting with number 1.

Label in Selected Image - this control elements
enables to type/delete label into/from the image
selected on the workspace. This control element is
active, when an image is selected on the workspace.

Following control elements enable setting appearance of the labels.

Note

The units can be changed in module options: Edit → Options...

Background - this control element enables to set
a background behind labels. You can select either
None (Transparent) or one of the following
background shapes: Circle, Square or Rectangle.

Position - using this control element you can define
a position of a label in the image.

Offset - these control elements enable to define
a label's offset from an image corner in units defined
in module Options.
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Font - using these control elements you can define
type and size of labels font. If the option Invert
Colors is not checked, the font color will be black.
If background display is set in the Background part,
a black label will be displayed on a white
background. If you check the Invert Colors option,
the font color will be white. If background display
is set in the Background part, a white label will be
displayed on a black background.

Apply to All Inserted Labels - if you perform any
changes in settings of a label in any of the images
on the workspace, you can apply all those changes
to all labels inserted into images on the workspace
at once by clicking this button.

6. Status Bar
Status bar located in a bottom part of the module window, displays information about
dimensions of a selected image in a final figure. In right side corner of the status bar, control
elements for zooming of the workspace are located. Workspace zoom can be also controlled
by the mouse wheel, if the mouse cursor is placed above the workspace.
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Work with Figure Maker Module
1. General Information about Projects

Figure Maker module works with so called projects.

A project file contains:

• All imported images including calibration information and image descriptions
• Information about layout and zoom of images on the workspace, displayed areas, scale

bars and labels
• Project description
• Figure export settings

This functionality enables to load all necessary information from a single file and continue
working when you finished last time. Project files use a proprietary format with .fmp
extension.

2. Module Launch
For Figure Maker module launch proceed as follows:

1. If you want to import images opened in QuickPHOTO program into the Figure Maker
module, select them in the Thumbnail Browser of the QuickPHOTO program first.
Thumbnails of selected images will be framed. Selection of multiple images can be
done similarly to Windows® Explorer (continuous selection using Shift key and
a discontinuous one using Ctrl key).

2. Run the Figure Maker module from Modules → Figure Maker menu or click the
icon in the Toolbar.

3. In the opened Project Selection dialog window you can create a new project or open
an existing one.
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• New Project - this button opens a wizard for creating a new project.

• New Project from Selected Images - this button opens a wizard for creating a new
project and after its creating it automatically imports images selected in the
Thumbnail Browser of the QuickPHOTO program.

• Open Project - this button enables to open an existing stored project.

• Recent Projects - you can quickly open one of the recently opened project from
a displayed list.

3. Creating a New Project
1. In the Project Selection dialog window click the New Project or the New Project from

Selected Images button.

2. A Project Properties wizard with opened Canvas tab appears.
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Define required resolution and canvas size using the following control elements at
this tab.

Note

Workspace is an area, into which the images can be placed. The workspace is
displayed by white color in the preview.

Canvas comprises a workspace + possible borders around it. The borders are
displayed by grey color in the preview. Images cannot be placed into an area of
the borders.

Resolution: this parameter enables to define a resolution of
a workspace (and the resulting figure) in DPI units. Set the
resolution according to requirements of your publisher or your
requirements on print quality. The resolution value can be
chosen from the list or a custom value can be typed.
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Units: using this control element you can select units in which
the workspace should be defined.

Note

Standard pica or also American pica corresponds to 0.16604 inch; i.e. 4.217 mm.

Typographic pica or also PostScript pica corresponds to 1/6 inch; i.e. 4.233 mm.

Canvas Size: you can select one of the
predefined European or international paper
sizes with desired sheet orientation or
define a custom size.

Borders: If one of the predefined paper
sizes was selected, the borders can also be
set. Images cannot be placed into an area
of the borders. Borders will not be
included in an exported figure.

Preview: this part interactively displays a preview of the currently defined canvas.
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Workspace Dimensions: information about the dimensions of the currently defined
workspace (excluding possible borders) are displayed in selected units and pixels.

Continue by the Next button.

3. A Grid tab appears. You can define number of columns and rows of an auxiliary grid
at this tab.

The grid can be used for defining layout of images on the workspace and it can be
set/modified anytime later.

Click the Finish button. Workspace of a newly created project appears. If use have
chosen the New Project from Selected Images option, the images selected in the
Thumbnail Browser of the QuickPHOTO program will be automatically imported
into the project.
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Note

Dimension and resolution of a workspace can be changed later when workspace

is empty by clicking the button in the Toolbar or using the Edit →
Canvas Properties... option from the menu bar.

4. Importing Images
In order to be able to place images to the workspace, they need to be imported to the current
project first.

The images can be imported in two ways:

1. Importing Images from the QuickPHOTO Program
This way enables to import images opened in the QuickPHOTO program; you can import
e.g. recently acquired images without a need of their prior saving.

Import procedure is following:

1. Switch to main window of the QuickPHOTO program.

2. Assign corresponding calibration (select the calibrated objective and zoom values in
the drop-down menus in the Toolbar) to all images you want to import to the Figure
Maker module, and into which you want to insert scale bars.

3. Select the images you want to import into the current project in the Thumbnail browser.

4.
Switch to the Figure Maker module and click the button in the Toolbar
or activate the Edit → Import Images... option from the menu bar. An Import Images
dialog window with two options appears.
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5. Select the Images from the Main Program option and click the Next button. Images
will be imported and they will be displayed in Thumbnail Browser of the Figure Maker
module.

Note

When importing images this way, all object inserted into the images in the
QuickPHOTO program (scale bars, measuring objects and annotations) will be
automatically merged with the images. All those objects will be visible in the
Figure Maker module, but there will be no option to modify, hide or delete them.

2. Importing of Stored Images
The images can also be imported into the Figure Maker module directly from a hard drive,
flash memory etc.
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In order to import stored images into current project, click the button in the
Toolbar or activate the Edit → Import Images... option from the menu bar of the Figure
Maker module. An Import Images dialog window with two options appears. Select the
Stored Images option and click the Next button. In the opened dialog window select one
or multiple images of a JPEG, TIFF, PNG or BMP type intended for importing. Click the
Open button. Images will be imported and they will be displayed in Thumbnail Browser
of the Figure Maker module.
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Note

When importing images this way, objects inserted into images in theQuickPHOTO
program (scale bars, measuring objects and annotations), which are stored in
a separate layer, will not be visible in the Figure Maker module. If you want the
inserted objects to be visible in the Figure Maker module, it is necessary to save
the images intended for this way of importing with merged layers by the
QuickPHOTO program. For more information about saving of images, please
refer to the QuickPHOTO program user guide. Calibration information and
descriptions contained in images of a JPEG or TIFF type will be read by the Figure
Maker module in all cases (regardless of the saving method) and the option to
insert scale bars into them will be available. For that reason it is recommended
to assign corresponding calibration (objective and zoom vales in the drop-down
menus in the Toolbar) prior to their saving by QuickPHOTO program.

5. Placing Images into Workspace, Defining
Dimensions, Displayed Areas and Zoom, Moving

Images
The Figure Maker module enables to place whole images into the workspace without a need
to crop them in order to display only their desired areas. The image sizes, aspect ratios,
displayed areas and their zoom can be defined after placing the whole images into the
workspace following the procedures described in following sections.

Placing Images into the Workspace
Images displayed in the Thumbnail Browser of the Figure Maker module can be placed
into the workspace in the following ways:

• By clicking the Insert Image into the Workspace icon in the Thumbnail Browser or
by double clicking on the thumbnail. If a grid is displayed on the workspace, this way
will always place one image in one free grid cell and adjust its size. If a grid is not
displayed on the workspace, the images will be placed side by side from the top left
corner of the workspace in 100% zoom, if there is enough space for them. If there is
not enough space for placing the images in 100% zoom, the zoom will be adjusted to
fit the free space.
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• Drag and drop of a thumbnail into the workspace. This method places an image to the
workspace in 100% zoom, if there is enough free space for it. If there is not enough
space for placing the image in 100% zoom, the zoom will be adjusted to fit the free
space.

Images, which are placed on the workspace, have an orange square with a number displayed
in the upper left corner of the thumbnail. The number indicates how many times is the
particular image present on the workspace. Images, which do not have an orange square
displayed in the thumbnail are not yet placed on the workspace. Each image can be placed
to the workspace multiple times and each time a different area of it can be displayed.

Setting Dimensions, Zoom and Displayed Areas
Each image is automatically selected and marked with an orange frame with green grip
points (squares) along its perimeter after its placing into the workspace.

These grip points can be used to resize the image on the workspace as follows:

• Corner grip points - dragging these points maintains the aspect ratio of the image and
changes its size and zoom.

• Gripping points in the middle of the edges - dragging these points inwards into the
image changes the aspect ratio of its sides and reduces it in the selected direction. Only
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part of the inserted image will be displayed. Dragging outwards increases the displayed
portion of the image in the selected direction, or moves the displayed area or changes
its zoom.

Note

Information about the dimensions of the selected image in the resulting figure is
displayed in the status bar of the module.

Zoom and a displayed area of the image can be set by a Navigator.

The slider beneath the Navigator with the editable drop-down menu allow you to select
the zoom of the image selected on the workspace. The part of the image that is currently
displayed on the workspace is framed with an orange rectangle in the Navigator. The other
parts of the image are grayed out. Moving the orange rectangle in the Navigator allows
you to display the desired area of the image on the workspace. You can also change the
zoom of the image by moving the mouse cursor over the image selected on the workspace,
then by pressing and holding the Ctrl key and turning the mouse wheel. Press the mouse
wheel and drag to move the displayed area directly on the workspace. If you want to specify
a desired exact zoom value, you can type it into the editable drop-drown menu next to the
slider. If you type a value, which is outside of the available zoom range, the value will be
automatically corrected.
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Important

To achieve the best print quality, it is recommended, if possible, not to set zoom
higher than 100%.

Moving Images
Any image can be grasped and dragged to another free space on the workspace. The image
can be dragged into the free space of the workspace even over the other placed images.
While dragging an image over the other images, a squared place holder image appears. If
the image fits into the new place, it will be placed in it. If the image does not fit into a new
place, it will be returned to its original position after the left mouse button is released. You
can also move the selected image precisely using the cursor keys.

Editing of Placed Images
If you want to edit an image placed on the workspace, always click the mouse to select it
first. It can then be edited arbitrarily.

Removing Images from the Workspace
If you want to remove an image from the workspace, select it by a mouse click first. Then
remove it by clicking Remove Selected Image from the Workspace button in the
Thumbnail Browser or by Delete key.

Deselecting an Image
Deselecting of an image can be done by selection of another one, by right mouse click or
by clicking the left mouse button into an empty spot of the workspace.

6. Image Snapping
The Figure Maker module, for easier and more accurate placement, when resizing or
moving images snaps them to the grid, the edges of the workspace, and the already-placed
images. If snapping occurs, horizontal or vertical blue dashed lines highlighting the edges
to which the image is being snapped appear on the workspace.
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Snapping can be temporarily suppressed by holding down the Ctrl key while resizing or
moving the image, or completely switched off using Edit → Snap to Images and Edit →
Snap to Grid and Edges options from the menu bar.

7. Grid
On the workspace, it is possible to display an auxiliary grid for easier and more accurate
image size and layout definition. The grid can be set up when creating a new project or at

any time later. To display or edit a grid in the current project, click the button
in the Toolbar or select Edit → Grid Properties... option from the menu bar. Project
Properties dialog window opens with the Grid tab displayed. In Grid Properties part you
can select the number of grid columns and rows.
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Cell dimension information is displayed interactively in the Grid Cell Dimensions part in
the units selected when creating the project and also in pixels. The grid preview is displayed
interactively in the Preview part. The grid settings can be changed at any time, even if
images are placed on the workspace.

8. Scale Bars
You can insert scale bars into the images on the workspace. The lengths of the inserted
scale bars are automatically adjusted to match the specified value when changing the zoom
of images on the workspace.

In order to be able to insert scale bars into images, they must contain a calibration
information from theQuickPHOTO program. If an image contains a calibration information,

indicator next to its thumbnail in the Thumbnail Browser and the information about
used magnification e.g. Objective: 0.75; Zoom: 0.8 under information about its dimensions
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in pixels are displayed. If an image does not contain a calibration information (indicator
is not displayed), it is not possible insert a scale bar into it.

Note

Calibration information contains a calibration value, a calibration name and an
information about used magnification.

If you are using the Figure Maker module in QuickPHOTO program in version
3.0, information about the calibration name and the used magnification will not
be available for images imported from the QuickPHOTO program. Only the
calibration value will be imported and only the indicator will be displayed next
to the corresponding thumbnail. It is still possible to insert scale bars into such
images.

Setting Scale Bar Parameters
The required length, units, and scale bar appearance can be set using the following elements
on the Scale Bar tab:
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Note

The units can be changed in module options: Edit → Options...

Length - using this control element you can define a desired scale
bar length and units. You can select one of the predefined values
from the first drop-down menu or type desired value into it. Units
can be selected in the second drop-down menu.

Thickness - using this control element you can define a scale bar
thickness in units selected in module Options.

Position - using this control element you can define
a position of a scale bar in the image.
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Offset - these control elements enable to define
a scale bar's offset from an image corner in units
defined in module Options.

Appearance - using these control elements you can
define appearance of a scale bar:

Invert Colors - if this option is not checked, a scale
bar will be inserted as a black bar. If the Display
Background option is checked, a black scale bar will
be placed on a white background. If you check the
Invert Colors option, a scale will be inserted as
a white bar instead of a black one. If the Display
Background option is checked, a white scale bar will
be placed on a black background.

Display Value - if this option is not checked, a scale
bar will be inserted as a bar without any numerical
value. If you check this option, a scale bar will be
inserted along with a numerical value displaying its
length in units selected in Length part. You can also
define whether the value should be positioned above
or under a scale bar. Furthermore you can define, if
a background should be displayed behind a scale bar
and its value using the Display Background option.

Font - using these control elements you can set font
and size of a scale bar length value.

Insertion of Scale Bar(s)
A scale bar can be inserted into an image in two ways:

• Bulk insertion into all images on the workspace
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• Scale bar insertion into a selected image

Bulk Scale Bar Insertion into all Images on the Workspace

If you want to insert scale bars with length, units, and appearance set by the above described
control elements into all the images on the workspace, click one of the following buttons:

Horizontal button inserts horizontal and Vertical
button inserts vertical scale bar into all images on
the workspace containing calibration information.

Scale Bar Insertion into a Selected Image

If you want to insert a scale bar into a particular image on the workspace, select it by
clicking the left mouse button first. To insert a scale bar with the defined length, units, and
appearance, click one of the following buttons:

Horizontal button inserts/hides horizontal scale bar
in the image selected on the workspace. Vertical
button inserts/hides vertical scale bar in the image
selected on the workspace.

These buttons also serve as indicators, whether the scale bar is inserted into the selected
image. If a horizontal scale bar is inserted in the selected image, the Horizontal button is
pressed. The vertical scale bar presence is indicated in a similar way. If you want to remove
the scale bar from the selected image, click on the pressed button.

Changing the Scale Bar Parameters
If you want to change the parameters of an inserted scale bar in an image on the workspace,
select it with the mouse first. Then, change the desired parameters using the setting elements
mentioned above. The changes will display interactively in the selected image.
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Apply Changes to All Images on the Workspace
If you want to apply the changes also to all the other images on the workspace, click one

of the buttons or the button.

9. Labels
You can also insert labels, that most often have a form of letters or a numeric designation,
in images on the workspace.

Setting Label Parameters
The desired appearance of labels can be set using the following elements on the Labels
tab:

Note

The units can be changed in module options: Edit → Options...
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Background - this control element enables to set
a background behind labels. You can select either
None (Transparent) or one of the following
background shapes: Circle, Square or Rectangle.

Position - using this control element you can define
a position of a label in the image.

Offset - these control elements enable to define
a label's offset from an image corner in units defined
in module Options.

Font - using these control elements you can define
type and size of labels font. If the option Invert
Colors is not checked, the font color will be black.
If background display is set in the Background part,
a black label will be displayed on a white
background. If you check the Invert Colors option,
the font color will be white. If background display
is set in the Background part, a white label will be
displayed on a black background.

Insertion of Labels
Labels can be inserted into images in two ways:

• Automatic insertion of labels into all images on the workspace
• Inserting a custom label into the selected image

Automatic Insertion of Labels into All Images on the Workspace
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If you want to insert labels with appearance set by the above mentioned control elements
into all the images on the workspace, click one of the following buttons:

A,B,C,... button automatically labels all images on
the workspace by capital letters starting with A letter.
a,b,c,... button automatically labels all images on
the workspace by lowercase letters starting with a
letter. 1,2,3,... button automatically numbers all
images on the workspace starting with number 1.

Automatic label insertion runs from the top left corner of the workspace to the right and
then down.

If you change the order of images, that already have the labels inserted, on the workspace,
you can update the order of the labels according to the above described system by next
click on corresponding above mentioned button. Similarly, it is also possible to change
the numbering of images to labeling by the letters, etc.

Inserting a Custom Label into the Selected Image

If you want to insert labels into images in a way other than automatic insertion offers, you
can type in the required texts by the keyboard. First, by clicking the left mouse button,
select the image into which you want to write a custom label, and then type the desired
text in the Label in Selected Image field.

Deleting a Label
If you want to delete a label from an image, select it by a mouse click first, and then delete
the text from the Label in Selected Image field.
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Changing Parameters of an Inserted Label
If you want to change parameters of an inserted label in an image on the workspace, select
it by a mouse click first. Then use the above mentioned control elements to adjust the
desired label parameters. The changes will display interactively in the selected image.

Apply Changes to All Images on the Workspace
If you want to apply the changes also to all the other images on the workspace, click one

of the buttons or the button.

10. Project Description
You can write a text description of the project, that will be saved as part of the project file.

To write or read a project description, click the button in the Toolbar or
select Edit → Project Information... option from the menu bar. Project Properties dialog
window opens with the Information tab displayed.
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In Project Description part, it is possible to write/read a description of the current project.
The entire description can be deleted by clicking theDelete Description button. To confirm
changes to the project description, always click the OK button. If you close the dialog
window by clicking the Cancel button, the changes made will be ignored.

The Project File Location part shows the location of the current project file.

11. Exporting Figures
If you have finished the layout of the images on the workspace, including the optional
insertion of scale bars and labels, you can export the resulting figure for publishing purposes.

To export, press or select File → Export Figure... option from the menu bar.
The following dialog window opens in which export parameters can be set:
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Control elements in the Borders section allow you to set the framing of individual images
in the exported figure:

If you want to frame individual images in the exported figure, check the Borders of
Particular Images option. This enables the Border Thickness and Color controls to adjust
the thickness and color of the frames. The framing is always done inwards so that the
frames overlap the edges of the images. The offsets of scale bars and labels will be
automatically adjusted during exporting process to match the defined values.

The control elements in Spaces part allow you to adjust the spaces between individual
images in the exported figure:
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If you want to cut out spaces among the images, check the Cut out Spaces Among Images
option and select the thickness of the spaces, in the units selected in the program options,
using the Space Thickness option. Cutting out the spaces is always done inwards so that
the spaces cut the edges of the images. The offsets of scale bars and labels will be
automatically adjusted during exporting process to match the defined values.

The figure background can be set in Background part:

Following parameters can be set in the Export Settings part:

Export as Grey Scale Image - the figure will be exported as a grey scale image for
monochromatic publications.

Open Exported Figure in Default Image Viewer - opens the exported figure in default
image viewer right after exporting.

Set the desired export parameters and click the Next button. The Save as dialog window
appears. Select the desired location, name and type of the exported figure, and then click
the Save button. The image will be exported.

Note

If you save the project file after figure exporting, it will be saved including the
used exporting parameters.

Exported figure with the image framing and cutting out spaces among images set can look
e.g. like the following one:
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12. Options
Edit → Options... option from the menu bar opens a dialog window enabling settings of
several parameters of the module:
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Control element in the Units part enables selection of units used for adjusting offsets and
thicknesses:

Controls in the Default Folders part allow you to preset the default folders for importing
images, exporting figures, and saving and loading project files. That way it will not be
necessary to browse the entire directory structure of your computer when working with
files:
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Tips and Recommendations for Work
with Figure Maker Module

In order to achieve best results when working with the Figure Maker module follow these
recommendations:

1. Place the images on the workspace tightly together without any spaces among them.
If you want to make spaces among the images in the figure, choose their cut out during
the figure exporting. Inserted scale bars and labels will automatically be moved when
the spaces are cut out to maintain their set offsets.

2. Creating figures can be extremely demanding on the computer's operating memory
for large dimensions and large DPI resolution of the workspace. To create large figures,
we recommend to have at least 4 GB of operating memory (RAM) on your computer
and, if possible, use a 64bit operating system. 64bit operating systems generally allow
programs to use more memory and therefore larger figures can be created.

3. If you want to insert drawings (such as arrows, frames, etc.) or text labels into the
images, do so using the tools of QuickPHOTO program before importing images to
the Figure Maker module.
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System Requirements
Minimal Computer Specification:

• Single-core 2.4 GHz or multi-core processor
• 2 GB RAM
• DVD drive
• Microsoft® Windows® 7/8/8.1/10

Recommended Computer Specification:

• Intel Core® i5 processor or better
• 4 GB RAM or more
• DVD drive
• Microsoft® Windows® 7/8/8.1/10 64bit

Supported QuickPHOTO programs:

• QuickPHOTO CAMERA 3.0 and newer
• QuickPHOTO MICRO 3.0 and newer
• QuickPHOTO INDUSTRIAL 3.0 and newer

Microsoft®, Windows® are registered trade marks of Microsoft Corp.
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